How to switch PHP versions in Minpache September 4, 2019

For developer's convenience we've been distributing a install-free bundle of Apache and PHP, also known as "Minpache". This bundle is intended to be compatible with most of the Win32 environments without any VC run-time complication.

For proper 64-bit integer support and updated SSL, a newer version of PHP is needed. Use the following steps to point to a newer PHP while keeping the original Minpache PHP intact:

1. download the mod_fcgid.so binary; copy it to the modules folder

2. download the non-thread safe version of PHP 7.2 (64-bit) (32-bit); extract to c:\php7

3. modify conf/httpd.conf

#LoadModule php5_module "php5apache2_2.dll"

LoadModule fcgid_module modules/mod_fcgid.so

FcgidInitialEnv PHPRC        "c:/php7"
AddHandler fcgid-script .php  
FcgidWrapper "c:/php7/php-cgi.exe" .php
FcgidMaxRequestLen 20971250

Note that the default Fcgi request length has a limit of only 128K! In the above configuration, we set the max to 20MB.

Our Services

Targeted Crawlers

Crawlers for content extraction, restoration and competitive intelligence gathering.

Learn More

Gyroscope™ ERP Solutions

Fully integrated enterprise solutions for rapid and steady growth.

Learn More

E-Commerce

Self-updating websites with product catalog and payment processing.

Learn More